Token Refresh for 'connection name' failed

What Happened?

Issue:

You will received an email with the subject “Token refresh for ‘connection name’ failed”.

Impact:

Tasks using this connection will no longer succeed.

Root Cause:

This happens because an OAuth enabled connection cannot be refreshed with the respective connection API. Here are some common causes:

  • An outage on the application platform, causing the sliding refresh token to expire.
  • The refresh token issued by the application platform may have a hard expiry date.
  • The refresh token has been revoked by the application platform.

How can you fix it?

Resolution

You will need to re-authorize the connection by following these steps:

  1. Navigate to the connections.

oauth5

  1. Click Edit on the affected connection.

oauth6

  1. Click on Manage Additional Security.

oauth1

  1. Click on Generate Redirect URI.

  2. Click Authorize which is located on the bottom right.

oauth2

  1. You will be redirected to the application platform consent page. Click on allow access.

  2. You will be redirected back to Loome. Click on Continue on the popup model, then Next on the main page.

oauth4

  1. Continue with the setup of your connection.